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Verkada Dome Camera Maintenance

Learn how to care for your Verkada Dome Camera

Updated over 4 months ago

There may be times when the image quality of your camera may be affected because of dust, debris, fingerprints, moisture, condensation, and so on. Occasional maintenance is recommended to keep your cameras functioning properly.

Common issues and how to resolve

Internal reflection

Cause

When the camera case is not attached properly to the camera body, the infrared (IR) glare reflects off the dome into the lens and back onto the dome.

Solution

Re-attach the camera case to the camera body and fully tighten the Torx screws.

The image on the left shows circular images caused by reflection. The image on the right shows the image after the camera's case is attached properly.

Circular patterns After camera case attached

External occlusion

Cause

When the protective film is not removed after installation, it causes an IR glare.

Solution

Remove the protective film from the dome. The camera may need to be refocused after removing the film.

The image on the left shows the protective film making the image look blurry and out of focus with a unique mosaic pattern effect. The image on the right shows the image after the protective film is removed.

With protective film on (blurry image) After protective film is removed

Dust, debris, or fingerprints on the dome

Cause

When dust or debris accumulates on the dome, the image looks fine in Day Mode. However, in Night Mode, the IR glare reflects off the dust and debris, causing bright spots and loss of contrast in the image.

Solution

Use canned air to blow away dust and debris and then clean the camera dome.

The image on the left shows the image with bright spots and loss of contrast while some portions remain in focus. The image on the right shows the image after the dome has been cleaned.

Dust and debris on dome (contrast loss) After cleaning the dome

Fingerprints on dome After cleaning the dome


Need more help? Contact Verkada Support.

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